Wednesday, June 17, 2020

Search boxes not working (+workaround)

The search boxes on the CPRR.org website, unfortunately, have stopped working, falsely reporting "No results found"

This is a search engine bug related to the search being of both the CPRR Museum website (at CPRR.org) and the CPRR discussion group (at discussion.cprr.net).

For example if you search for "railroad" the search box generates the following search, using a comma:
"railroad site:CPRR.org,discussion.cprr.net"
which no longer works.

WORKAROUND:
To correct the search, so that it correctly returns results, all you have to do is to change the search to:
"railroad site:CPRR.org OR site:discussion.cprr.net"
(instead of using a comma and without the quotes) and resubmit.


Of course, instead of railroad, use the search term(s) that you actually want to find.

What's really weird is that this new bug affects multiple search engines: DuckDuckGo, Google, and Bing.
Has the syntax for multiple site searches changed? If so, why haven't the search engines updated their handling of site search boxes so that searches will still work?

Can anyone explain what is going on, or have a better workaround???

Can anyone suggest how to modify the webpage code URL that DuckDuckGo generates for the sitesearch box,
https://duckduckgo.com/search.html?site=CPRR.org,discussion.cprr.net&prefill=Search CPRR Museum
so that it generates the correct "OR site:" syntax, instead of the broken "," syntax?

2 Comments:

Blogger CPRR Discussion Group said...

The following bug report has been repeatedly submitted to DuckDuckGo, with no fix, and no response:

To: open@duckduckgo.com
From: museum@CPRR.org
Subject: Search Box Bug- Multiple site search has stopped working

Bug report: The multiple site search syntax (comma between sites) no longer works, falsely returning no search results. Help!!! [3rd bug report on this issue]

Your search box instructions say:
"Site search: ex: yourwebsite.com (For multiple sites, separate with commas: yourwebsite.com,anotherwebsite.com)"
https://duckduckgo.com/search_box

So,

site=yourwebsite.com,anotherwebsite.com

generates a nonworking search syntax "site:yourwebsite.com,anotherwebsite.com" (now fails, starting about a month ago, by returning no search results)

but the syntax which your seach box code does NOT generate,

"site:yourwebsite.com OR site:anotherwebsite.com"

succeeds.

***Please fix your code so that DuckDuckGo sitesearch boxes will start returning search results again.***

Example:

The search box at
http://CPRR.org/Museum/Exhibits.html
when searching for "railroad" generates the following failed search (no search results):

https://duckduckgo.com/?q=railroad+site%3ACPRR.org%2Cdiscussion.cprr.net&atb=v35-2&ia=web

when searching for,
"railroad site:CPRR.org,discussion.cprr.net"

But, if I manually modify the search to
"railroad site:CPRR.org OR site:discussion.cprr.net"
I get a working search, as follows,

https://duckduckgo.com/?q=railroad+site%3ACPRR.org+OR+site%3Adiscussion.cprr.net&atb=v35-2&ia=web

Thanks!

6/17/2020 9:27 AM  
Anonymous Anonymous said...

Also see, The ultimate guide to DuckDuckGo.

6/17/2020 10:21 AM  

Post a Comment

<< Recent Messages